Wednesday, April 18, 2007

HPUX: Tips Gestion des Packages

Installer un package en ligne

swinstall -v -x allow_multiple_versions=true -x verbose=1 -x mount_all_filesystems=false -s "$depot" "$name"

ou $depot => xpm-3.4k-hppa-11.00.depot
et $name => xpm


Enlever un package récalcitrant

- swremove to remove package in swlist's host system
- stop/start of swagentd
- enforce_dependencies=false in swremove option while removing from depot.


Lister les programmes installé: swlist

Liste des produits:
$ swlist -l product

Liste des fileset:
$ swlist -l fileset

Liste des depot:
$ swlist -l depot
$ swlist -s mmstyy00:/

List all products with revision and description for each:
$ swlist all product | more

List all filesets which have a state other than configured:
$ swlist all fileset a state | grep -v -e '^#' -e configured

List all patches in the depot /var/MyDepot on the system grendel:
$ swlist -d -l product *,c=patch @ grendel:/var/MyDepot

List the filesets modified by installed patch PHSS_8675
$ swlist -a ancestor PHSS_8675

List all of the files delivered within patch PHCO_12140 after downloading from the ITRC:
$ swlist -d -l file @ /tmp/PHCO_12140.depot

List all the files delivered within product:
$ swlist -l file HP-APA-KRN

List all patches that have modified the LVM product
$ swlist -l patch LVM

Display the documentation for all patches containing critical functionality
$ swlist -a readme -l product *,c=critical

List all category tags defined in the depot /var/MyDepot on the system grendel
$ swlist -d -l category @ grendel:/var/MyDepot


Lire le Readme d'un package


swlist -s mmsdyy00:/SD_CDROM -a readme J5316AA


Commit patches

Efface la sauvegarde faite dans "/var/adm/sw/save/"
$ swmodify -x patch_commit=true '*.*'

Création

Créer un .depot

$ swpackage -x target_type=tape -s \* @ /tmp/isee_customise.depot
$ swpackage -x target_type=tape -s NomPackage @ /tmp/NomPackage.depot


Enregistrer le depot

$ swreg -l depot

*Supprimer l'accés distant
$ swreg -u -l depot

Préparation

$ swcopy -x enforce_dependencies=false -s / ISEEPlatform @
$ swask -s ISEE-Chorus

Résultat dans: /catalog/ISEE-Chorus/pfile/response

ou encore:
# Depot=MCPS-SHC
$ swcopy -s MCPS-SHC @
$ swask -s MCPS-SHC

Install

swinstall -s mmstyy00:/


Procédure Complete

# Depot=MCPS-SHC
$ swacl -l root -M user:root@:a
$ swcopy -s MCPS-SHC @
$ swinstall -s MCPS-SHC
$ swask -s MCPS-SHC
$ swinstall -s MCPS-SHC @ hostA hostB

Gestion des droits

- Pour autoriser l'utilisateur marie à ajouter de nouveaux produits au dépôt :
$ swacl -l depot -M user:marie:a [@ hôte:dépôt]

- Pour autoriser l'utilisateur marie à modifier les produits existants d'un dépôt :
$ swacl -l product -M user:marie:a \* [@ hôte]

- Pour modifier le modèle de telle sorte que l'utilisateur marie puisse modifier les nouveaux produits créés par d'autres dans le dépôt :
$ swacl -l global_product_template -M user:marie:a [@ hôte]


Pour authoriser un utilisateur distant à gérer un depot:

# Exemple: user=unix host=mmsdyy00 depot=/mkenv/sw-depot
# A executer sur mmstyy00

$ swacl -l depot -M user:unix@mmsdyy00:a @ /mkenv/sw-depot
$ swacl -l depot -M user:root@mmsdyy00:a @ /mkenv/sw-depot
$ swacl -l depot -M host:mmsdyy00:a @ /mkenv/sw-depot


$ swacl -l depot -M host:mmsdyy00:a
$ swacl -l product -M host:mmsdyy00:a \*
$ swacl -l global_product_template -M host:mmsdyy00:a


Lister les droits d'un dépot:

$ swacl -l depot @ /mkenv/sw-depot

No comments: